Header Background

Networking & Switches

Getting the PXE configured

Admittedly, the biggest and probably only obstacle to using our software is to initially set up the network correctly so that a PXE boot is possible.

Depending on the switches used, the firmware version and the desired network configuration, you must set up the configuration according to the switch instructions.

Here are a few examples of typical configurations:

Arista Switches in MLAG LACP:

Switch A:
=======
interface Port-Channel101
   switchport trunk native vlan 100
   switchport trunk allowed vlan 100,101
   switchport mode trunk
   port-channel min-links 1
   port-channel lacp fallback individual
   port-channel lacp fallback timeout 5
   mlag 101
!
interface Ethernet10/1
   description "LACP to storage server #1"
   switchport access vlan 100
   channel-group 101 mode active
   lacp port-priority 14000
!

Switch B:
=======
interface Port-Channel101
   switchport trunk native vlan 100
   switchport trunk allowed vlan 100,101
   switchport mode trunk
   port-channel min-links 1
   port-channel lacp fallback individual
   port-channel lacp fallback timeout 5
   mlag 101
!
interface Ethernet10/1
   description "LACP to storage server #1"
   switchport access vlan 100
   channel-group 101 mode active
   lacp port-priority 15000
!

Juniper Switches in LACP:

Switch A:
=======
set interfaces xe-0/0/0 ether-options 802.3ad lacp force-up

Cisco Switches in LACP:

Switch A:
=======
interface Ethernet1/1
  lacp rate fast
  switchport
  switchport access vlan 100
  channel-group 1 mode active
  no shutdown

interface port-channel1
  switchport
  switchport access vlan 100
  no lacp suspend-individual
  vpc 1