Network Configuration

#Getting the PXE configured

Admittedly, the biggest and probably only obstacle to using our software is to initially set up the network correctly so that a PXE boot is possible.

Depending on the switches used, the firmware version and the desired network configuration, you must set up the configuration according to the switch instructions.

Here are a few examples of typical configurations:

Arista Switches in MLAG LACP:

Switch A:
=======
interface Port-Channel101
   switchport trunk native vlan 100
   switchport trunk allowed vlan 100,101
   switchport mode trunk
   port-channel min-links 1
   port-channel lacp fallback static
   port-channel lacp fallback timeout 5
   mlag 101
!
interface Ethernet10/1
   description "LACP to storage server #1"
   switchport access vlan 100
   channel-group 101 mode active
   lacp port-priority 14000
!

Switch B:
=======
interface Port-Channel101
   switchport trunk native vlan 100
   switchport trunk allowed vlan 100,101
   switchport mode trunk
   port-channel min-links 1
   port-channel lacp fallback static
   port-channel lacp fallback timeout 5
   mlag 101
!
interface Ethernet10/1
   description "LACP to storage server #1"
   switchport access vlan 100
   channel-group 101 mode active
   lacp port-priority 15000
!

Juniper Switches in LACP:

Switch A:
=======
set interfaces xe-0/0/0 ether-options 802.3ad lacp force-up

#Replacing NICs

  1. shut down the server (croit will mark the server as offline after 2 minutes)
  2. change the NIC's MAC address to the replacement NIC's MAC address
  3. swap the NICs
  4. boot the server